Move from haml 4 to haml 5 (to prepare for rails 5.1)


(Priit Pärna) #1

I’m moving to rails 5.1.0.beta1 and also to haml 5.0.0.beta.2 but that’s a dependency inside pushtype as well.

Bundler could not find compatible versions for gem "haml":
  In Gemfile:
    haml (~> 5.0.0.beta.2)

    push_type was resolved to 0.10.4, which depends on
      push_type_admin (= 0.10.4) was resolved to 0.10.4, which depends on
        haml-rails (~> 0.9) was resolved to 0.9.0, which depends on
          haml (< 5.0, >= 4.0.6)

    push_type was resolved to 0.10.4, which depends on
      push_type_admin (= 0.10.4) was resolved to 0.10.4, which depends on
        haml-rails (~> 0.9) was resolved to 0.9.0, which depends on
          html2haml (>= 1.0.1) was resolved to 2.1.0, which depends on
            haml (~> 4.0)

(Aaron Russell) #2

Thanks for raising this. I need to update the dependencies and release a new version for rails 5.1. I’m away for a another week so won’t be able to sort this until after 20 march, but will let you know once sorted.


(Aaron Russell) #3

@chemic I’ve put a new beta gem out today (0.11.0.beta.1) which is hopefully Rails 5.1 ready. As for haml, this ones outside of my control right now as we’re using haml-rails - as soon as that’s upgraded I’ll update the dependency.

Haml 4 should still work fine, but it does spit out a few deprecation messages.