Update to work with newer sass


(Chris Giddings) #1

Installing the push_type gem and attempting to rake without doing a bundle update fails due to a time-boxed assignment on the push_type gem’s compatibility with the sass gem.

Newer editions of sass exist, and push_type should be updated to work with something more recent.

While it’s reasonable to expect a ruby developer to know to simply bundle update, those new to ruby may get lost in a labyrinthine attempt to require specific versions of various other gems or get frustrated and quit push_type before discovering its power and flexibility…


(Aaron Russell) #2

Hi there, thanks for reporting this. I’ll be getting a release out in the next few days that is Rails 5.2 compatible so the gemspecs should be all up to date when that’s done.


(Chris Giddings) #3

Sweet! I look forward to it!


(Chris Giddings) #4

I haven’t seen a newer release hit yet. Is there some complication?


(Lorne) #5

Just going to add a couple of notes to this…

My project is using bootstrap (~> 4.0.0), which depends on sass (>= 3.5.2).

Even the newest version of foundation-rails depends on sass (< 3.5, >= 3.3.0).

Also appears there are other people coming across similar things https://github.com/zurb/foundation-rails/issues/256

Not super helpful sorry, but thought it was worth noting!


(Aaron Russell) #6

Sorry, there is a beta version out. There was one or two minor issues in github that I havn’t closed off yet, hence still with beta tag, but you should be fine with this and Rails 5.2:

https://rubygems.org/gems/push_type/versions/0.12.0.beta.1